Problemas de conexión con ADSL Telefónica

Síntomas:

- Tenías configurado adsl para que se conectara automáticamente al iniciar el sistema y ahora no se conecta.
- Te conectas pero puedes navegar por algunas páginas solamente, como www.google.cl, pero si buscas algo en google, y quieres entrar a una web encontrada, queda cargando eternamente.

Las soluciones que he aplicado son dos hasta el momento.

1.- Configurar nuevamente adsl (sudo pppoeconf) y en el momento que te pregunta por si actualiza automáticamente los DNS en /etc/resolv.conf, le dices que NO. Luego de configurar eso pones manualmente los DNS en aquel archivo. Abre un terminal (se puede hacer gráficamente, pero para mí es más rápido como lo voy a explicar) en el menú Aplicaciones->Accesorios->Terminal.

sudo gedit /etc/resolv.conf
se abrira una ventanita, pones lo siguiente:
nameserver 200.28.4.129
nameserver 200.28.4.130
Ojo que estos numeritos (200.28.4.129 y 200.28.4.130, varían según el país en el que vivas) ... luego guardas y cierras la ventanita.

2.- Ahora editas otro archivo
sudo nano /etc/ppp/options
y busca estas lineas:

# Set the MTU [Maximum Transmit Unit] value to . Unless the peer
# requests a smaller value via MRU negotiation, pppd will request that
# the kernel networking code send data packets of no more than n bytes
# through the PPP network interface.
#mtu
y dejalo así:
# Set the MTU [Maximum Transmit Unit] value to . Unless the peer
# requests a smaller value via MRU negotiation, pppd will request that
# the kernel networking code send data packets of no more than n bytes
# through the PPP network interface.
mtu 1412
(Sacarle el Gato, y poner el mtu 1412)... Cierra todo y guardas los cambios. Reinicia tu equipo y ya deberías estar perdiendo el tiempo en facebook (maldito facebook xD ).
Nota: Cabe mencionar, que si estás usando algún router, deberás buscar como modificar este valor en la configuración del router.

¿Cual(es) es(son) el(los) problema(s) que causa(n) estas fallas?. La verdad no he querido averiguar, solo me limito a solucionar el problema jejeje. Y no es solo en Ubuntu (prejuicioso/a), he tenido estos mismos problemas con Windows Vista.

Cambio y fuera ;)


1 comentarios:

winux dijo...

ke kisiste decir con perder el tiempo en facebook a XD